Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2025 - 15:00 CEST
Scheduled
On Monday 2025-06-23 15:00 PM CET we will upgrade OSD to version 3.2 as well as OSD-ISO. Application downtime will be minimum and will include OSD and Ballots.
We apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jun 19, 2025 - 22:27 CEST
This scheduled maintenance affected: Development of standards (CEN Ballots on Draft Standards, CEN Online Standards Development (OSD)).